<!DOCTYPE html>
<html lang="en-US">
<head>
	<!-- onecount code -->
	<!-- <script type='text/javascript' src="https://airage-validate.onecount.net/clients/AIRAGE/js/oc-all.min.js"></script>
	<script type='text/javascript' src="https://airage-validate.onecount.net/clients/AIRAGE/js/a.js"></script> -->
	<meta charset="UTF-8" />
<meta name="viewport" content="initial-scale=1.0" />
<title>Jeti Transmitter Bracket Handle - Model Airplane News</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://www.modelairplanenews.com/xmlrpc.php" />

<!-- This site is optimized with the Yoast SEO Premium plugin v4.4 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://www.modelairplanenews.com/jeti-transmitter-bracket-handle/" />
<meta property="DC.date.issued" content="2017-03-28T16:08:30-04:00" />
<!-- / Yoast SEO Premium plugin. -->

<link rel="alternate" type="application/rss+xml" title="Model Airplane News &raquo; Feed" href="http://www.modelairplanenews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Model Airplane News &raquo; Comments Feed" href="http://www.modelairplanenews.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Model Airplane News &raquo; iCal Feed" href="http://www.modelairplanenews.com/eventcalendar/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Model Airplane News &raquo; Jeti Transmitter Bracket Handle Comments Feed" href="http://www.modelairplanenews.com/jeti-transmitter-bracket-handle/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/www.modelairplanenews.com\/wp-includes\/js\/wp-emoji-release.min.js?aaver=e5ddfddaf4"}};
			!function(a,b,c){function d(a){var c,d,e,f=b.createElement("canvas"),g=f.getContext&&f.getContext("2d"),h=String.fromCharCode;if(!g||!g.fillText)return!1;switch(g.textBaseline="top",g.font="600 32px Arial",a){case"flag":return g.fillText(h(55356,56806,55356,56826),0,0),f.toDataURL().length>3e3;case"diversity":return g.fillText(h(55356,57221),0,0),c=g.getImageData(16,16,1,1).data,d=c[0]+","+c[1]+","+c[2]+","+c[3],g.fillText(h(55356,57221,55356,57343),0,0),c=g.getImageData(16,16,1,1).data,e=c[0]+","+c[1]+","+c[2]+","+c[3],d!==e;case"simple":return g.fillText(h(55357,56835),0,0),0!==g.getImageData(16,16,1,1).data[0];case"unicode8":return g.fillText(h(55356,57135),0,0),0!==g.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='category-box-shortcode-css'  href='http://www.modelairplanenews.com/wp-content/plugins/category-box/css/shortcode.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<link rel='stylesheet' id='login-with-ajax-css'  href='http://www.modelairplanenews.com/wp-content/plugins/login-with-ajax/widget/widget.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<link rel='stylesheet' id='shadowbox-css-css'  href='http://www.modelairplanenews.com/wp-content/uploads/shadowbox-js/src/shadowbox.css?aaver=e5ddfddaf4' type='text/css' media='screen' />
<link rel='stylesheet' id='shadowbox-extras-css'  href='http://www.modelairplanenews.com/wp-content/plugins/shadowbox-js/css/extras.css?aaver=e5ddfddaf4' type='text/css' media='screen' />
<link rel='stylesheet' id='dashicons-css'  href='http://www.modelairplanenews.com/wp-includes/css/dashicons.min.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='http://www.modelairplanenews.com/wp-includes/js/thickbox/thickbox.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<link rel='stylesheet' id='fancy-slideshow-css'  href='http://www.modelairplanenews.com/wp-content/plugins/sponsors-slideshow-widget/style.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.modelairplanenews.com/wp-content/plugins/contact-form-7/includes/css/styles.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='http://www.modelairplanenews.com/wp-content/plugins/wp-polls/polls-css.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('http://www.modelairplanenews.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='category-posts-css'  href='http://www.modelairplanenews.com/wp-content/plugins/category-posts/cat-posts.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<link rel='stylesheet' id='style2-os-css-css'  href='http://www.modelairplanenews.com/wp-content/plugins/gallery-video/style/style2-os.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<link rel='stylesheet' id='lightbox-css-css'  href='http://www.modelairplanenews.com/wp-content/plugins/gallery-video/style/lightbox.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<link rel='stylesheet' id='videogallery-all-css-css'  href='http://www.modelairplanenews.com/wp-content/plugins/gallery-video/style/videogallery-all.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css-css'  href='http://www.modelairplanenews.com/wp-content/plugins/gallery-video/style/css/font-awesome.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<link rel='stylesheet' id='ris-slider-css-css'  href='http://www.modelairplanenews.com/wp-content/plugins/ultimate-responsive-image-slider/css/slider-pro.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<link rel='stylesheet' id='ub_adminbar_general_styles-css'  href='http://www.modelairplanenews.com/wp-content/plugins/ultimate-branding/ultimate-branding-files/modules/custom-admin-bar-files/css/general.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='http://www.modelairplanenews.com/wp-content/themes/frontier/style.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<link rel='stylesheet' id='fancybox-css-css'  href='http://www.modelairplanenews.com/wp-content/themes/frontier-child/css/jquery.fancybox.min.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<link rel='stylesheet' id='oswald-style-css'  href='https://fonts.googleapis.com/css?family=Oswald&#038;ver=4.5.7' type='text/css' media='all' />
<link rel='stylesheet' id='Teko-style-css'  href='https://fonts.googleapis.com/css?family=Teko&#038;ver=4.5.7' type='text/css' media='all' />
<link rel='stylesheet' id='Titillium-style-css'  href='https://fonts.googleapis.com/css?family=Titillium+Web&#038;ver=4.5.7' type='text/css' media='all' />
<link rel='stylesheet' id='core-css'  href='http://www.modelairplanenews.com/wp-content/themes/frontier-child/css/frontier-custom.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<link rel='stylesheet' id='frontier-font-css'  href='//fonts.googleapis.com/css?family=Roboto+Condensed%3A400%2C700%7CArimo%3A400%2C700&#038;ver=4.5.7' type='text/css' media='all' />
<link rel='stylesheet' id='frontier-icon-css'  href='http://www.modelairplanenews.com/wp-content/themes/frontier/includes/genericons/genericons.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<link rel='stylesheet' id='frontier-main-css'  href='http://www.modelairplanenews.com/wp-content/themes/frontier-child/style.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<link rel='stylesheet' id='frontier-responsive-css'  href='http://www.modelairplanenews.com/wp-content/themes/frontier/responsive.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<link rel='stylesheet' id='author-avatars-widget-css'  href='http://www.modelairplanenews.com/wp-content/plugins/author-avatars/css/widget.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<link rel='stylesheet' id='author-avatars-shortcode-css'  href='http://www.modelairplanenews.com/wp-content/plugins/author-avatars/css/shortcode.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<link rel='stylesheet' id='wpmu-wpmu-ui-3-min-css-css'  href='http://www.modelairplanenews.com/wp-content/plugins/popover/inc/external/wpmu-lib/css/wpmu-ui.3.min.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<link rel='stylesheet' id='wpmu-animate-3-min-css-css'  href='http://www.modelairplanenews.com/wp-content/plugins/popover/inc/external/wpmu-lib/css/animate.3.min.css?aaver=e5ddfddaf4' type='text/css' media='all' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.0.16 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-2191912-12', 'auto', {'allowAnchor':true,'allowLinker':true});
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('send','pageview');
</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-includes/js/jquery/jquery.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-includes/js/jquery/jquery-migrate.min.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/plugins/login-with-ajax/widget/login-with-ajax.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/www.modelairplanenews.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-includes/js/thickbox/thickbox.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/plugins/sponsors-slideshow-widget/js/jquery.cycle2.min.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/plugins/sponsors-slideshow-widget/js/jquery.cycle2.carousel.min.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/plugins/sponsors-slideshow-widget/js/jquery.cycle2.flip.min.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/plugins/sponsors-slideshow-widget/js/jquery.cycle2.scrollVert.min.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/plugins/sponsors-slideshow-widget/js/jquery.cycle2.shuffle.min.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/plugins/sponsors-slideshow-widget/js/jquery.cycle2.tile.min.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/plugins/sponsors-slideshow-widget/js/jquery.cycle2.caption2.min.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/plugins/sponsors-slideshow-widget/js/jquery.cycle2.swipe.min.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/plugins/sponsors-slideshow-widget/js/jquery.easing.1.3.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/plugins/wonderplugin-lightbox/engine/wonderpluginlightbox.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/themes/frontier-child/js/frontier-custom.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/themes/frontier-child/js/jquery.sticky.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/themes/frontier-child/js/jquery.fancybox.min.js?aaver=e5ddfddaf4'></script>
<link rel='https://api.w.org/' href='http://www.modelairplanenews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.modelairplanenews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.modelairplanenews.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.5.7" />
<link rel='shortlink' href='http://www.modelairplanenews.com/?p=250217' />
<link rel="alternate" type="application/json+oembed" href="http://www.modelairplanenews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.modelairplanenews.com%2Fjeti-transmitter-bracket-handle%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.modelairplanenews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.modelairplanenews.com%2Fjeti-transmitter-bracket-handle%2F&#038;format=xml" />
<link rel="image_src" href="http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-1-300x176.jpg" />				<script src="//connect.facebook.net/en_US/all.js" type="text/javascript"></script>
			<!-- <meta name="NextGEN" version="2.1.50" /> -->

<!--Plugin WP Missed Schedule 2013.0130.2222 Active - 64Bit Security Tag Key: bkytCi8L522P8RbgYIlkQbL6Yz4JDvIWlTlXN5q776Yvq5t7gxkCvB643C7osdFV6-->

<meta property="Frontier Theme" content="1.2.4" />
<style type="text/css" media="screen">
	#container 	{width: 960px;}
	#header 	{min-height: 0px;}
	#content 	{width: 65%;}
	#sidebar-left 	{width: 35%;}
	#sidebar-right 	{width: 35%;}
</style>

<style type="text/css" media="screen">
	.page-template-page-cs-php #content, .page-template-page-sc-php #content {width: 65%;}
	.page-template-page-cs-php #sidebar-left, .page-template-page-sc-php #sidebar-left,
	.page-template-page-cs-php #sidebar-right, .page-template-page-sc-php #sidebar-right {width: 35%;}
	.page-template-page-scs-php #content {width: 50%;}
	.page-template-page-scs-php #sidebar-left {width: 25%;}
	.page-template-page-scs-php #sidebar-right {width: 25%;}
</style>

	
	<!-- Woopra code starts here -->
	<script>
		(function(){
		var t,i,e,n=window,o=document,a=arguments,s="script",r=["config","track","identify","visit","push","call"],c=function(){var t,i=this;for(i._e=[],t=0;r.length>t;t++)(function(t){i[t]=function(){return i._e.push([t].concat(Array.prototype.slice.call(arguments,0))),i}})(r[t])};for(n._w=n._w||{},t=0;a.length>t;t++)n._w[a[t]]=n[a[t]]=n[a[t]]||new c;i=o.createElement(s),i.async=1,i.src="//static.woopra.com/js/w.js",e=o.getElementsByTagName(s)[0],e.parentNode.insertBefore(i,e)
		})("woopra");
		woopra.config({"app":"wordpress","domain":"modelairplanenews.com","download_tracking":true,"outgoing_tracking":true,"hide_campaign":false});
		woopra.track("wp article", {"author":"Trevor &quot;Chilly&quot; Duncan","category":"New Gear","permalink":"http:\/\/www.modelairplanenews.com\/jeti-transmitter-bracket-handle\/","title":"Jeti Transmitter Bracket Handle","post date":1490717310000}); 
	</script>
	<!-- Woopra code ends here -->
	
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #f1f1f1; }
</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Jeti Transmitter Bracket Handle" />
<meta property="og:url" content="http://www.modelairplanenews.com/jeti-transmitter-bracket-handle/" />
<meta property="og:description" content="From Esprit Tech: Jeti USA now offers a Handle to help you carry your Jeti Transmitter. Sometimes you just need a better grip on things, and now that is possible with the new Handle. Simply install…" />
<meta property="article:published_time" content="2017-03-28T20:08:30+00:00" />
<meta property="article:modified_time" content="2017-03-28T20:08:30+00:00" />
<meta property="og:site_name" content="Model Airplane News" />
<meta property="og:image" content="http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-1.jpg" />
<meta property="og:image:width" content="900" />
<meta property="og:image:height" content="529" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:image" content="http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-1.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- Custom CSS -->
<style type="text/css" media="screen">
body.newbg { 
  background: url("http://www.flightjournal.com/wp-content/uploads/2016/10/bgFlight-copy.jpg") no-repeat center center fixed !important; 
  -webkit-background-size: cover;
  -moz-background-size: cover;
  -o-background-size: cover;
  background-size: cover;
}
#main {
    background-color: transparent !important;
}
</style>
<!-- Custom CSS End -->

</head>

<body class="single single-post postid-250217 single-format-standard custom-background tribe-no-js">
	<!-- Clcik Tracking code -->
	<img src="http://66.228.114.178/genie/api/merchant/campaign/tracker/Transparent?AdvertiserName=AirAgeMedia&AdvertiserId=16&CampaignName=ModelAirplane&CampaignId=2&StrategyName=Prospecting&StrategyId=2&CreativeName=ModelPlane523&CreativeId=3&StartDate=default" >
	
	
<div id="container" class="cf">
		<input type="hidden" class="current_user_email" value="" />
	<div id="header-widget">
		<div id="text-106" class="widget-1 widget-first widget-last widget-odd widget-header frontier-widget widget_text">			<div class="textwidget"><a href='http://prod2.airage.com/cirrata/www/delivery/ck.php?oaparams=2__bannerid=150__zoneid=30__cb=91a925a38a__oadest=http%3A%2F%2Fwww.explore-rise.com%2Fchallenge' target='_blank'><img src='http://prod2.airage.com/cirrata/www/images/ff137f722b2fb97f86e731a1df12d55c.jpg' width='900' height='250' alt='Hobbico HR Challenge V1 900x250' title='Hobbico HR Challenge V1 900x250' border='0' /></a><div id='beacon_91a925a38a' style='position: absolute; left: 0px; top: 0px; visibility: hidden;'><img src='http://prod2.airage.com/cirrata/www/delivery/lg.php?bannerid=150&amp;campaignid=50&amp;zoneid=30&amp;loc=http%3A%2F%2Fwww.modelairplanenews.com%2Fjeti-transmitter-bracket-handle%2F&amp;cb=91a925a38a' width='0' height='0' alt='' style='width: 0px; height: 0px;' /></div></div>
		</div>	</div>
				
		<div id="top-bar" class="cf">
			
			<div id="top-bar-info">
				
							</div>

							<nav id="nav-top">
					<ul id="menu-top-bar-nav" class="nav-top"><li id="menu-item-245347" class="rcc-logo menu-item menu-item-type-custom menu-item-object-custom menu-item-245347"><a href="http://rccaraction.com/">RCC</a></li>
<li id="menu-item-245348" class="map-logo menu-item menu-item-type-custom menu-item-object-custom menu-item-245348"><a href="http://modelairplanenews.com/">MAP</a></li>
<li id="menu-item-245349" class="fj-logo menu-item menu-item-type-custom menu-item-object-custom menu-item-245349"><a href="http://www.flightjournal.com/">FLJ</a></li>
<li id="menu-item-245350" class="dc-logo menu-item menu-item-type-custom menu-item-object-custom menu-item-245350"><a href="http://www.diecastxmagazine.com/">DC</a></li>
<li id="menu-item-245351" class="rd-logo menu-item menu-item-type-custom menu-item-object-custom menu-item-245351"><a href="http://www.rotordronemag.com/">RD</a></li>
<li id="menu-item-245352" class="rcx-logo menu-item menu-item-type-custom menu-item-object-custom menu-item-245352"><a href="http://rcx.com/">RCX</a></li>
<li id="menu-item-245353" class="aas-logo menu-item menu-item-type-custom menu-item-object-custom menu-item-245353"><a href="https://www.airagestore.com/">AAS</a></li>
</ul>				</nav>
			
			<div class="ajaxlogin"><span><strong>Log In</strong></span><div>	<strong>Access Premium Site</strong><span style="font-size:2em;">&raquo;</span>
	<div id="LoginWithAjax" class="default">        <div id="LoginWithAjax_Status"></div>
        <form name="LoginWithAjax_Form" id="LoginWithAjax_Form" action="http://www.modelairplanenews.com/wp-login.php?callback=?&amp;template=" method="post">
            <table width='100%' cellspacing="0" cellpadding="0">
                <tr id="LoginWithAjax_Username">
                    <td class="username_label">
                        <label>Email</label>
                    </td>
                    <td class="username_input">
                        <input type="text" name="log" id="lwa_user_login" class="input" value="" />
                    </td>
                    <td class="password_label">
                        <label>Password</label>
                    </td>
                    <td class="password_input">
                        <input type="password" name="pwd" id="lwa_user_pass" class="input" value="" />
                    </td>
                </tr>
                <tr><td colspan="4"></td></tr>
                <tr id="LoginWithAjax_Submit">
                    <td id="LoginWithAjax_SubmitButton">
                        <input type="submit" name="wp-submit" id="lwa_wp-submit" value="Log In" tabindex="100" />
                        <input type="hidden" name="redirect_to" value="http://www.modelairplanenews.com/jeti-transmitter-bracket-handle/" />
                        <input type="hidden" name="testcookie" value="1" />
                        <input type="hidden" name="lwa_profile_link" value="" />
                    </td>
                    <td id="LoginWithAjax_Links" colspan="3">
                        <input name="rememberme" type="checkbox" id="lwa_rememberme" value="forever" /> <label>Remember Me</label>
                        &nbsp;&nbsp;&nbsp;&nbsp;<a id="LoginWithAjax_Links_Remember" href="http://www.modelairplanenews.com/wp-login.php?action=lostpassword" title="Password Lost and Found">Get New Password</a>
                                            </td>
                </tr>
            </table>
        </form>
        <form name="LoginWithAjax_Remember" id="LoginWithAjax_Remember" action="http://www.modelairplanenews.com/wp-login.php?action=lostpassword&amp;callback=?&amp;template=" method="post" style="display:none;">
            <table width='100%' cellspacing="0" cellpadding="0">
                <tr>
                    <td>
                        <strong>Create a New Password</strong>         
                    </td>
                </tr>
                <tr>
                    <td class="forgot-pass-email">  
                                                <input type="text" name="user_login" id="lwa_user_remember" value="Enter username or email" onfocus="if(this.value == 'Enter username or email'){this.value = '';}" onblur="if(this.value == ''){this.value = 'Enter username or email'}" />   
                    </td>
                </tr>
                <tr>
                    <td>
                        <input type="submit" value="Get New Password" />
                          <a href="#" id="LoginWithAjax_Links_Remember_Cancel">Cancel</a>
                        <input type="hidden" name="login-with-ajax" value="remember" />         
                    </td>
                </tr>
            </table>
        </form>
	</div>
    <div style="font-size:1em;">Not a member? <a href="http://www.airagestore.com/distributors/man-premium" target="_blank">Join today</a>!</div>
	</div></div>		</div>
		<div id="sticky-header">
			<div id="header" class="cf">
			
							<div id="header-logo">
					<a href="http://www.modelairplanenews.com/"><img src="//www.modelairplanenews.com/wp-content/uploads/2016/01/MAN_Logo-small.png" alt="Model Airplane News" /></a>
				</div>
			
					</div>
	
			
		<nav id="nav-main" class="cf drop">
			
							<a href="#" class="drop-toggle"><span class="genericon genericon-menu"></span></a>
			
			<ul id="menu-main-nav-rcc" class="nav-main"><li id="menu-item-245339" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-245339"><a href="#">Explore</a>
<ul class="sub-menu">
	<li id="menu-item-245340" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-245340"><a href="http://www.modelairplanenews.com/category/new-gear/">New Planes &#038; Gear</a></li>
	<li id="menu-item-245341" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-245341"><a href="http://www.modelairplanenews.com/category/how-tos/">How-tos</a></li>
	<li id="menu-item-245342" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-245342"><a href="http://www.modelairplanenews.com/category/fixed-wing-flight-school/">Flight Techniques</a></li>
	<li id="menu-item-245343" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-245343"><a href="http://www.modelairplanenews.com/category/workshop-build-alongs/">Workshop Build-Alongs</a></li>
	<li id="menu-item-245344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-245344"><a href="http://www.modelairplanenews.com/category/plans/">Construction Articles</a></li>
	<li id="menu-item-245354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-245354"><a href="http://www.modelairplanenews.com/category/video-picks/">Video Picks</a></li>
	<li id="menu-item-245355" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-245355"><a href="http://www.modelairplanenews.com/category/event-coverage/">Event Coverage</a></li>
</ul>
</li>
<li id="menu-item-249168" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-249168"><a href="http://www.modelairplanenews.com/category/getting-started/">Getting Started</a>
<ul class="sub-menu">
	<li id="menu-item-249169" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-249169"><a href="http://www.modelairplanenews.com/category/getting-started/assembly-tips/">Assembly Tips</a></li>
	<li id="menu-item-249170" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-249170"><a href="http://www.modelairplanenews.com/category/getting-started/flight-success/">Flight Success</a></li>
	<li id="menu-item-249171" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-249171"><a href="http://www.modelairplanenews.com/category/getting-started/power-systems/">Power Systems</a></li>
	<li id="menu-item-249172" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-249172"><a href="http://www.modelairplanenews.com/category/getting-started/radio-systems/">Radio Systems</a></li>
	<li id="menu-item-249173" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-249173"><a href="http://www.modelairplanenews.com/category/getting-started/product-picks/">Product Picks</a></li>
</ul>
</li>
<li id="menu-item-245412" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-245412"><a href="#">Digital Edition</a>
<ul class="sub-menu">
	<li id="menu-item-245413" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245413"><a href="http://www.modelairplanenews-digital.com/man/current">Model Airplane News Digital</a></li>
	<li id="menu-item-245414" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245414"><a href="http://itunes.apple.com/us/app/airplane-news/id473236546?mt=8">Model Airplane News iPhone App</a></li>
	<li id="menu-item-245415" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245415"><a href="https://play.google.com/store/apps/details?id=com.texterity.android.MAN">Model Airplane News Android App</a></li>
	<li id="menu-item-245416" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245416"><a href="http://search.barnesandnoble.com/Model-Airplane-News/Air-Age-Media/e/2940043959485">Model Airplane News Nook Version</a></li>
	<li id="menu-item-245417" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245417"><a href="http://www.electricflight-digital.com/electricflight/current">Electric Flight Digital</a></li>
	<li id="menu-item-245418" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245418"><a href="http://itunes.apple.com/us/app/electric-flight/id516067524?mt=8">Electric iPhone Flight App</a></li>
	<li id="menu-item-245419" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245419"><a href="https://play.google.com/store/apps/details?id=com.texterity.android.ElectricFlight">Electric Flight Android App</a></li>
	<li id="menu-item-245420" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245420"><a href="http://www.barnesandnoble.com/w/electric-flight-air-age-media/1111527532?ean=2940043959614">Electric Flight Nook Version</a></li>
	<li id="menu-item-245421" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-245421"><a href="http://www.modelairplanenews.com/faqs/">FAQs</a></li>
</ul>
</li>
<li id="menu-item-245346" class="nav-subscribe-menu menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-245346"><a href="#">Subscribe</a>
<ul class="sub-menu">
	<li id="menu-item-245356" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245356"><a href="https://www.circsource.com/store/Subscribe.html?magazineId=354&#038;sourceCode=I1BBNN">Model Airplane News Print + Digital</a></li>
	<li id="menu-item-245357" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245357"><a href="http://www.airagestore.com/magazines/subscriptions/model-airplane-news-digital-edition-one-full-year-12-issues.html">Model Airplane News Digital Only</a></li>
	<li id="menu-item-245358" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245358"><a href="http://www.airagestore.com/planes/memberships/one-full-year-of-exclusive-member-access-for-only-24-95.html">ModelAirplaneNews.com Premium</a></li>
	<li id="menu-item-245365" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245365"><a href="https://www.circsource.com/store/Subscribe.html?magazineId=354&#038;type=gift&#038;sourceCode=I8AGNN">Model Airplane News Gift Subscription</a></li>
	<li id="menu-item-245359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245359"><a href="https://www.circsource.com/store/Subscribe.html?magazineId=356&#038;sourceCode=I1BBNN">Electric Flight Print + Digital</a></li>
	<li id="menu-item-245360" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245360"><a href="http://www.airagestore.com/magazines/subscriptions/electric-flight-digital.html">Electric Flight Digital Only</a></li>
	<li id="menu-item-245366" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245366"><a href="https://www.circsource.com/store/Subscribe.html?magazineId=356&#038;type=gift&#038;sourceCode=I8AGNN">Electric Flight Gift Subscription</a></li>
	<li id="menu-item-245361" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245361"><a href="https://www.circsource.com/store/renewalLogin.html?MagId=354">Model Airplane News Renew</a></li>
	<li id="menu-item-245362" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245362"><a href="https://secure.palmcoastd.com/pcd/eServ?iServ=MDY3QUw0MjA0Nw==">Customer Service Model Airplane News</a></li>
	<li id="menu-item-245423" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-245423"><a href="http://www.modelairplanenews.com/help-contact-us/">Help – Contact Us – Model Airplane News</a></li>
	<li id="menu-item-245363" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245363"><a href="https://www.circsource.com/store/renewalLogin.html?MagId=356">Electric Flight Renew</a></li>
	<li id="menu-item-245364" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245364"><a href="https://secure.palmcoastd.com/pcd/eServ?iServ=MDY3QU00MTk4Mg==">Customer Service Electric Flight</a></li>
	<li id="menu-item-245422" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-245422"><a href="http://www.modelairplanenews.com/help-contact-us-electric-flight/">Help – Contact Us – Electric Flight</a></li>
	<li id="menu-item-245424" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-245424"><a href="http://www.modelairplanenews.com/faqs/">FAQs</a></li>
</ul>
</li>
<li id="menu-item-249578" class="the-latest-from-userend menu-item menu-item-type-custom menu-item-object-custom menu-item-249578"><a href="#">The Latest From<br /></a></li>
<li id="menu-item-249579" class="the-latest-form menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-249579"><a href="#" onclick="__gaTracker('send', 'event', 'download', '#');" title="02/28/2017">The Latest From<br /></a>
<ul class="sub-menu">
	<li id="menu-item-249580" class="latest-from-start menu-item menu-item-type-custom menu-item-object-custom menu-item-249580"><a href="https://www.diecastxmagazine.com/">//rotordronemag.com/wp-content/themes/frontier-child/images/DCXgrey.png</a></li>
	<li id="menu-item-249581" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-249581"><a href="https://www.flightjournal.com/">//rotordronemag.com/wp-content/themes/frontier-child/images/FJGrey.png</a></li>
	<li id="menu-item-249582" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-249582"><a href="https://modelairplanenews.com">//rotordronemag.com/wp-content/themes/frontier-child/images/Mangrey.png</a></li>
</ul>
</li>
</ul>
			<div class="site-search"><span><img src="/wp-content/uploads/2016/01/small-search-24x24.png" /></span></div>		</nav>
	
			<div id="below-menu" class="cf">
			<div id="widgets-wrap-below-menu" class="cf"><div id="search-2" class="widget-1 widget-first widget-last widget-odd widget-below-menu frontier-widget widget_search"><form role="search" method="get" id="searchform" class="searchform" action="http://www.modelairplanenews.com/">
	<div>
		<input type="text" value="" name="s" id="s" />
		<input type="image" src="/wp-content/uploads/2016/01/small-search-24x24.png" alt="Submit" id="searchsubmit" value="Search" />
	</div>
</form></div></div>
		</div>
		</div>

<div id="main" class="col-cs cf">
<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.min.css">
	<div id="content" class="cf">

	
			
							<article id="post-250217" class="single-view post-250217 post type-post status-publish format-standard has-post-thumbnail hentry category-new-gear">


<header class="entry-header cf">
		<h1 class="entry-title"><a href="http://www.modelairplanenews.com/jeti-transmitter-bracket-handle/">Jeti Transmitter Bracket Handle</a></h1>
	</header>
<div class="entry-byline cf">
	
			<div class="entry-author author vcard">
			<!--  -->
						<i class="genericon genericon-user"></i><a class="url fn" href="http://www.modelairplanenews.com/author/trevord/">Trevor "Chilly" Duncan</a>
		</div>
	
	<!-- 		<div class="entry-date">
			<i class="genericon genericon-day"></i><a class="updated" href="http://www.modelairplanenews.com/jeti-transmitter-bracket-handle/">March 28, 2017</a>
		</div>
	 -->

			<div class="entry-categories">
			<i class="genericon genericon-category"></i><a href="http://www.modelairplanenews.com/category/new-gear/" rel="category tag">New Gear</a>		</div>
	
			<div class="entry-comment-info">
			<i class="genericon genericon-comment"></i><a href="#comment-area">Comments</a>
		</div>
	
	
	</div>

			<div class="post-thumbnail">
				<div class="post-cover"><a href="http://www.modelairplanenews.com/jeti-transmitter-bracket-handle/" title="Jeti Transmitter Bracket Handle"><img src="http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-1-640x300.jpg" alt="Jeti Transmitter Bracket Handle" class="Thumbnail thumbnail loop-main-big " width="640" /></a></div><!-- end .post-cover -->			</div><!-- .post-thumbnail -->
			
<div class="entry-content cf">
	
	
	<p><strong>From <a href="http://www.espritmodel.com" target="_blank">Esprit Tech</a>:</strong><br />
Jeti USA now offers a Handle to help you carry your Jeti Transmitter. Sometimes you just need a better grip on things, and now that is possible with the new Handle. Simply install it into your transmitter brackets! Available for DS and DC series transmitters. Works on the Transmitter Trays w/Brackets too!</p>
<p>#JETIJMS-DC-HFT &#8211; Jeti Transmitter Bracket Handle DC &#8211; $18.00<br />
#JETIJMS-DS-HFT &#8211; Jeti Transmitter Bracket Handle DS &#8211; $16.00<br />
<a href="http://www.espritmodel.com" target="_blank">Visit EspritModel.com</a><br />
<a href="http://www.modelairplanenews.com/?s=Esprit" target="_blank">See more posts about Esprit Tech</a></p>
<p><a href="http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-5.jpg" rel="shadowbox[sbpost-250217];player=img;"><img class="alignnone size-medium wp-image-250218" src="http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-5-300x273.jpg" alt="Jeti Transmitter Bracket Handle (5)" width="300" height="273" srcset="http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-5-300x273.jpg 300w, http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-5-768x699.jpg 768w, http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-5-500x455.jpg 500w, http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-5.jpg 900w" sizes="(max-width: 300px) 100vw, 300px" /></a> <a href="http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-1.jpg" rel="shadowbox[sbpost-250217];player=img;"><img class="alignnone size-medium wp-image-250219" src="http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-1-300x176.jpg" alt="Jeti Transmitter Bracket Handle (1)" width="300" height="176" srcset="http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-1-300x176.jpg 300w, http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-1-768x451.jpg 768w, http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-1-500x294.jpg 500w, http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-1.jpg 900w" sizes="(max-width: 300px) 100vw, 300px" /></a> <a href="http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-2.jpg" rel="shadowbox[sbpost-250217];player=img;"><img class="alignnone size-medium wp-image-250220" src="http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-2-300x232.jpg" alt="Jeti Transmitter Bracket Handle (2)" width="300" height="232" srcset="http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-2-300x232.jpg 300w, http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-2-768x595.jpg 768w, http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-2-500x387.jpg 500w, http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-2.jpg 900w" sizes="(max-width: 300px) 100vw, 300px" /></a> <a href="http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-3.jpg" rel="shadowbox[sbpost-250217];player=img;"><img class="alignnone size-medium wp-image-250221" src="http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-3-300x229.jpg" alt="Jeti Transmitter Bracket Handle (3)" width="300" height="229" srcset="http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-3-300x229.jpg 300w, http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-3-768x585.jpg 768w, http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-3-500x381.jpg 500w, http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-3.jpg 900w" sizes="(max-width: 300px) 100vw, 300px" /></a> <a href="http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-4.jpg" rel="shadowbox[sbpost-250217];player=img;"><img class="alignnone size-medium wp-image-250222" src="http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-4-300x267.jpg" alt="Jeti Transmitter Bracket Handle (4)" width="300" height="267" srcset="http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-4-300x267.jpg 300w, http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-4-768x683.jpg 768w, http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-4-500x444.jpg 500w, http://www.modelairplanenews.com/wp-content/uploads/2017/03/Jeti-Transmitter-Bracket-Handle-4.jpg 900w" sizes="(max-width: 300px) 100vw, 300px" /></a></p>

	
	
	
	</div>

<footer class="entry-footer cf">
	
			<div class="entry-updated updated">
			Updated: March 28, 2017 &mdash; 4:08 PM		</div>
	
			<div class="entry-tags"></div>
	
	</footer>

<div id="widgets-wrap-after-post" class="cf"><div id="text-125" class="widget-1 widget-first widget-odd track-banner-click widget-after-post frontier-widget widget_text">			<div class="textwidget"><a href='http://prod2.airage.com/cirrata/www/delivery/ck.php?oaparams=2__bannerid=147__zoneid=31__cb=22de44b2fb__oadest=http%3A%2F%2Fwww.explore-rise.com%2Fchallenge' target='_blank'><img src='http://prod2.airage.com/cirrata/www/images/fa7ab5b8100b0ed5462b377a9b64a3dc.jpg' width='600' height='120' alt='Hobbico HR Challenge V1 600x120' title='Hobbico HR Challenge V1 600x120' border='0' /></a><div id='beacon_22de44b2fb' style='position: absolute; left: 0px; top: 0px; visibility: hidden;'><img src='http://prod2.airage.com/cirrata/www/delivery/lg.php?bannerid=147&amp;campaignid=50&amp;zoneid=31&amp;loc=http%3A%2F%2Fwww.modelairplanenews.com%2Fjeti-transmitter-bracket-handle%2F&amp;cb=22de44b2fb' width='0' height='0' alt='' style='width: 0px; height: 0px;' /></div></div>
		</div><div id="text-126" class="widget-2 widget-last widget-even track-banner-click widget-after-post frontier-widget widget_text">			<div class="textwidget"><a href='http://prod2.airage.com/cirrata/www/delivery/ck.php?oaparams=2__bannerid=84__zoneid=34__cb=a609d40286__oadest=http%3A%2F%2Fwww.airagestore.com%2Fpromotions%2Fhomepage%2Fwhats-new-and-hot%2Ffpv-racer-photodrone-2602.html' target='_blank'><img src='http://prod2.airage.com/cirrata/www/images/6569ba11b2d62e1789dfea301471bdb8.jpg' width='600' height='120' alt='FPV/Photodrone 600x120' title='FPV/Photodrone 600x120' border='0' /></a><div id='beacon_a609d40286' style='position: absolute; left: 0px; top: 0px; visibility: hidden;'><img src='http://prod2.airage.com/cirrata/www/delivery/lg.php?bannerid=84&amp;campaignid=30&amp;zoneid=34&amp;loc=http%3A%2F%2Fwww.modelairplanenews.com%2Fjeti-transmitter-bracket-handle%2F&amp;cb=a609d40286' width='0' height='0' alt='' style='width: 0px; height: 0px;' /></div></div>
		</div></div>
</article>


	<div class="post-nav cf">
		<div class="link-prev"><a href="http://www.modelairplanenews.com/jeti-telemetry-sensor-fuel-flow-mflow2/" title="Jeti Telemetry Sensor Fuel Flow MFlow2">&#8592; Previous Post</a></div><div class="link-next"><a href="http://www.modelairplanenews.com/hobbyking-j3-navy-cub-ne-1-1400mm-pnp-video/" title="HobbyKing J3 Navy Cub (NE-1) 1400mm (PnP) [VIDEO]">Next Post &#8594;</a></div>	</div>

			<div id="comment-area">
<div id="comments">
	
					<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/jeti-transmitter-bracket-handle/#respond" style="display:none;">Cancel reply</a></small></h3>				<form action="http://www.modelairplanenews.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
					<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='250217' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="d5cbe81939" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="211"/></p>				</form>
					</div><!-- #respond -->
		</div></div>
					
	
	
	
	
</div>

<div id="sidebar-right" class="sidebar cf">
		<div id="widgets-wrap-sidebar-right">

					<div id="text-121" class="widget-1 widget-first widget-odd widget-sidebar frontier-widget widget_text"><h4 class="widget-title">Not a Member?</h4>			<div class="textwidget"><a HREF="http://www.airagestore.com/memberships/one-full-year-of-exclusive-member-access-for-only-24-95.html" target="_blank"><img SRC="//www.modelairplanenews.com/wp-content/uploads/2016/08/BothMemberButton.png" WIDTH="275" HEIGHT="58" BORDER="0" ALT=""/></a></div>
		</div><div id="text-114" class="widget-2 widget-even track-banner-click widget-sidebar frontier-widget widget_text"><h4 class="widget-title">Homepage Sidebar 1</h4>			<div class="textwidget"><a href='http://prod2.airage.com/cirrata/www/delivery/ck.php?oaparams=2__bannerid=157__zoneid=22__cb=b48f8fa005__oadest=http%3A%2F%2Fhitecrcd.com%2Fproducts%2Fchargers%2Facdc-chargers%2Fx4-ac-pro-acdc-four-port-multicharger%2Fproduct' target='_blank'><img src='http://prod2.airage.com/cirrata/www/images/c919eaaa3984cfbe1acb32b9ec65bd64.gif' width='275' height='125' alt='Hitec X4 AC Pro  275x125' title='Hitec X4 AC Pro  275x125' border='0' /></a><div id='beacon_b48f8fa005' style='position: absolute; left: 0px; top: 0px; visibility: hidden;'><img src='http://prod2.airage.com/cirrata/www/delivery/lg.php?bannerid=157&amp;campaignid=28&amp;zoneid=22&amp;loc=http%3A%2F%2Fwww.modelairplanenews.com%2Fjeti-transmitter-bracket-handle%2F&amp;cb=b48f8fa005' width='0' height='0' alt='' style='width: 0px; height: 0px;' /></div></div>
		</div><div id="text-113" class="widget-3 widget-odd track-banner-click widget-sidebar frontier-widget widget_text"><h4 class="widget-title">Homepage Sidebar 2</h4>			<div class="textwidget"><a href='http://prod2.airage.com/cirrata/www/delivery/ck.php?oaparams=2__bannerid=70__zoneid=23__cb=ce4ccd1da8__oadest=http%3A%2F%2Fcounters.hobbico.com%2Fgo.php%3Fs%3Dfutaba%26b%3Dman-fut-innovation-275x125.jpg' target='_blank'><img src='http://counters.hobbico.com/serve.php?b=man-fut-innovation-275x125.jpg' width='275' height='125' alt='FUT Luxury 275x125' title='FUT Luxury 275x125' border='0' /></a><div id='beacon_ce4ccd1da8' style='position: absolute; left: 0px; top: 0px; visibility: hidden;'><img src='http://prod2.airage.com/cirrata/www/delivery/lg.php?bannerid=70&amp;campaignid=27&amp;zoneid=23&amp;loc=http%3A%2F%2Fwww.modelairplanenews.com%2Fjeti-transmitter-bracket-handle%2F&amp;cb=ce4ccd1da8' width='0' height='0' alt='' style='width: 0px; height: 0px;' /></div>
</div>
		</div><div id="text-118" class="widget-4 widget-even track-banner-click widget-sidebar frontier-widget widget_text"><h4 class="widget-title">Homepage Sidebar 3</h4>			<div class="textwidget"><a href='http://prod2.airage.com/cirrata/www/delivery/ck.php?oaparams=2__bannerid=176__zoneid=24__cb=5e369ca348__oadest=http%3A%2F%2Fcounters.hobbico.com%2Fgo.php%3Fs%3Dfutk6110%26b%3Dman-futk6100-v2-275x125.gif' target='_blank'><img src='http://prod2.airage.com/cirrata/www/images/4dc4684625d9b46167a7a9c1278724f4.gif' width='275' height='125' alt='FUT 6K Transmitter 275x125' title='FUT 6K Transmitter 275x125' border='0' /></a><div id='beacon_5e369ca348' style='position: absolute; left: 0px; top: 0px; visibility: hidden;'><img src='http://prod2.airage.com/cirrata/www/delivery/lg.php?bannerid=176&amp;campaignid=27&amp;zoneid=24&amp;loc=http%3A%2F%2Fwww.modelairplanenews.com%2Fjeti-transmitter-bracket-handle%2F&amp;cb=5e369ca348' width='0' height='0' alt='' style='width: 0px; height: 0px;' /></div></div>
		</div><div id="text-115" class="widget-5 widget-odd track-banner-click widget-sidebar frontier-widget widget_text"><h4 class="widget-title">Homepage Sidebar 4</h4>			<div class="textwidget"><a href='http://prod2.airage.com/cirrata/www/delivery/ck.php?oaparams=2__bannerid=163__zoneid=25__cb=744860d942__oadest=http%3A%2F%2Fwww.airagestore.com%2Faviation%2Fspecial-issues%2Fworld-war-ii-s-first-dogfights-2636.html' target='_blank'><img src='http://prod2.airage.com/cirrata/www/images/e1b312f78919ca8665346079dd97de26.jpg' width='275' height='125' alt='First Dogfights 275x125' title='First Dogfights 275x125' border='0' /></a><div id='beacon_744860d942' style='position: absolute; left: 0px; top: 0px; visibility: hidden;'><img src='http://prod2.airage.com/cirrata/www/delivery/lg.php?bannerid=163&amp;campaignid=3&amp;zoneid=25&amp;loc=http%3A%2F%2Fwww.modelairplanenews.com%2Fjeti-transmitter-bracket-handle%2F&amp;cb=744860d942' width='0' height='0' alt='' style='width: 0px; height: 0px;' /></div>
</div>
		</div><div id="text-119" class="widget-6 widget-even track-banner-click widget-sidebar frontier-widget widget_text"><h4 class="widget-title">Homepage Sidebar 5</h4>			<div class="textwidget"><a href='http://prod2.airage.com/cirrata/www/delivery/ck.php?oaparams=2__bannerid=161__zoneid=26__cb=9b115c9d40__oadest=http%3A%2F%2Fwww.airagestore.com%2Fplanes%2Fspecial-issues%2Ffpv-racer-photodrone.html' target='_blank'><img src='http://prod2.airage.com/cirrata/www/images/1c8ecd5aeab771b142f0246d999b6b09.jpg' width='275' height='125' alt='FPV Racer 275x125' title='FPV Racer 275x125' border='0' /></a><div id='beacon_9b115c9d40' style='position: absolute; left: 0px; top: 0px; visibility: hidden;'><img src='http://prod2.airage.com/cirrata/www/delivery/lg.php?bannerid=161&amp;campaignid=30&amp;zoneid=26&amp;loc=http%3A%2F%2Fwww.modelairplanenews.com%2Fjeti-transmitter-bracket-handle%2F&amp;cb=9b115c9d40' width='0' height='0' alt='' style='width: 0px; height: 0px;' /></div></div>
		</div><div id="text-108" class="widget-7 widget-odd widget-sidebar frontier-widget widget_text"><h4 class="widget-title">Subscribe Now</h4>			<div class="textwidget"><img id="Image-Maps-Com-image-maps-2016-04-13-163621" src="//www.modelairplanenews.com/wp-content/uploads/2017/03/SubscribeSidebar.jpg" border="0" width="275" height="200" orgWidth="275" orgHeight="200" usemap="#image-maps-2016-04-13-163621" alt="" />
<map name="image-maps-2016-04-13-163621" id="ImageMapsCom-image-maps-2016-04-13-163621">
<area alt="" title="" href="https://www.circsource.com/store/Subscribe.html?magazineId=354&sourceCode=I1BBNR" shape="rect" coords="61,38,269,123" style="outline:none;" target="_blank"     />
<area alt="" title="" href="http://www.airagestore.com/magazines/digital/model-airplane-news-digital-edition-one-full-year-12-issues.html" shape="rect" coords="64,128,271,197" style="outline:none;" target="_blank"     />
<area shape="rect" coords="273,198,275,200" alt="Image Map" style="outline:none;" title="Image Map" href="http://www.image-maps.com/index.php?aff=mapped_users_0" />
</map></div>
		</div><div id="category-posts-2" class="widget-8 widget-even show-title widget-sidebar frontier-widget cat-post-widget"><h4 class="widget-title">Don't Miss</h4><ul>
				
				<li class="cat-post-item" >
					
												<!-- <a class="cat-post-thumbnail"								href="http://www.modelairplanenews.com/8-great-workshop-tips-2/" title="8 Great Workshop Tips">
								<img width="109" height="75" src="http://www.modelairplanenews.com/wp-content/uploads/2016/06/EF_14_3_0514_003_img004-300x206.jpg" class="attachment-134x75 size-134x75 wp-post-image" alt="EF_14_3_0514_003_img004" srcset="http://www.modelairplanenews.com/wp-content/uploads/2016/06/EF_14_3_0514_003_img004-300x206.jpg 300w, http://www.modelairplanenews.com/wp-content/uploads/2016/06/EF_14_3_0514_003_img004-500x343.jpg 500w, http://www.modelairplanenews.com/wp-content/uploads/2016/06/EF_14_3_0514_003_img004.jpg 504w" sizes="(max-width: 109px) 100vw, 109px" />							</a> -->
							<a href="http://www.modelairplanenews.com/8-great-workshop-tips-2/" title="8 Great Workshop Tips"><img src="http://www.modelairplanenews.com/wp-content/uploads/2016/06/EF_14_3_0514_003_img004-310x190.jpg" alt="8 Great Workshop Tips" class="Thumbnail thumbnail loop-main " width="310" height="190" /></a>										
					
					<a class="post-title  cat-post-title" 
						href="http://www.modelairplanenews.com/8-great-workshop-tips-2/" rel="bookmark">8 Great Workshop Tips					</a>

									</li>
								
				<li class="cat-post-item" >
					
												<!-- <a class="cat-post-thumbnail"								href="http://www.modelairplanenews.com/blog20161228blog20160322so-you-think-you-want-to-built-it-big/" title="So You Want to Build it Big! &#8212; Advice for Enlarging Model Airplanes">
								<img width="134" height="60" src="http://www.modelairplanenews.com/wp-content/uploads/2016/03/GregH2-300x134.jpg" class="attachment-134x75 size-134x75 wp-post-image" alt="gregh2" srcset="http://www.modelairplanenews.com/wp-content/uploads/2016/03/GregH2-300x134.jpg 300w, http://www.modelairplanenews.com/wp-content/uploads/2016/03/GregH2-768x344.jpg 768w, http://www.modelairplanenews.com/wp-content/uploads/2016/03/GregH2-500x224.jpg 500w, http://www.modelairplanenews.com/wp-content/uploads/2016/03/GregH2.jpg 878w" sizes="(max-width: 134px) 100vw, 134px" />							</a> -->
							<a href="http://www.modelairplanenews.com/blog20161228blog20160322so-you-think-you-want-to-built-it-big/" title="So You Want to Build it Big! &#8212; Advice for Enlarging Model Airplanes"><img src="http://www.modelairplanenews.com/wp-content/uploads/2016/03/GregH2-310x190.jpg" alt="So You Want to Build it Big! &#8212; Advice for Enlarging Model Airplanes" class="Thumbnail thumbnail loop-main " width="310" height="190" /></a>										
					
					<a class="post-title  cat-post-title" 
						href="http://www.modelairplanenews.com/blog20161228blog20160322so-you-think-you-want-to-built-it-big/" rel="bookmark">So You Want to Build it Big! &#8212; Advice for Enlarging Model Airplanes					</a>

									</li>
								
				<li class="cat-post-item" >
					
												<!-- <a class="cat-post-thumbnail"								href="http://www.modelairplanenews.com/install-a-smoke-system/" title="Install a Smoke System">
								<img width="75" height="75" src="http://www.modelairplanenews.com/wp-content/uploads/2015/10/MAN_143_10_1015_018_img0011-150x150.jpg" class="attachment-134x75 size-134x75 wp-post-image" alt="MAN_143_10_1015_018_img001[1]" srcset="http://www.modelairplanenews.com/wp-content/uploads/2015/10/MAN_143_10_1015_018_img0011-150x150.jpg 150w, http://www.modelairplanenews.com/wp-content/uploads/2015/10/MAN_143_10_1015_018_img0011-60x60.jpg 60w, http://www.modelairplanenews.com/wp-content/uploads/2015/10/MAN_143_10_1015_018_img0011-180x180.jpg 180w" sizes="(max-width: 75px) 100vw, 75px" />							</a> -->
							<a href="http://www.modelairplanenews.com/install-a-smoke-system/" title="Install a Smoke System"><img src="http://www.modelairplanenews.com/wp-content/uploads/2015/10/MAN_143_10_1015_018_img0011.jpg" alt="Install a Smoke System" class="Thumbnail thumbnail loop-main " width="310" height="190" /></a>										
					
					<a class="post-title  cat-post-title" 
						href="http://www.modelairplanenews.com/install-a-smoke-system/" rel="bookmark">Install a Smoke System					</a>

									</li>
								
				<li class="cat-post-item" >
					
												<!-- <a class="cat-post-thumbnail"								href="http://www.modelairplanenews.com/dle-engine-repair-video/" title="DLE Engine Repairs &#8212; Easy DIY fixes &#8212; Video How To">
								<img width="134" height="71" src="http://www.modelairplanenews.com/wp-content/uploads/2017/02/DLE-Engine-Repair--300x160.jpg" class="attachment-134x75 size-134x75 wp-post-image" alt="DLE Engine Repair" srcset="http://www.modelairplanenews.com/wp-content/uploads/2017/02/DLE-Engine-Repair--300x160.jpg 300w, http://www.modelairplanenews.com/wp-content/uploads/2017/02/DLE-Engine-Repair--768x409.jpg 768w, http://www.modelairplanenews.com/wp-content/uploads/2017/02/DLE-Engine-Repair--500x266.jpg 500w, http://www.modelairplanenews.com/wp-content/uploads/2017/02/DLE-Engine-Repair-.jpg 782w" sizes="(max-width: 134px) 100vw, 134px" />							</a> -->
							<a href="http://www.modelairplanenews.com/dle-engine-repair-video/" title="DLE Engine Repairs &#8212; Easy DIY fixes &#8212; Video How To"><img src="http://www.modelairplanenews.com/wp-content/uploads/2017/02/DLE-Engine-Repair--310x190.jpg" alt="DLE Engine Repairs &#8212; Easy DIY fixes &#8212; Video How To" class="Thumbnail thumbnail loop-main " width="310" height="190" /></a>										
					
					<a class="post-title  cat-post-title" 
						href="http://www.modelairplanenews.com/dle-engine-repair-video/" rel="bookmark">DLE Engine Repairs &#8212; Easy DIY fixes &#8212; Video How To					</a>

									</li>
								
				<li class="cat-post-item" >
					
												<!-- <a class="cat-post-thumbnail"								href="http://www.modelairplanenews.com/home-photo-shoot-full-spectrum-laser-cutter-review/" title="Desktop Laser Cutter &#8212; 40Watt hobby grade laser review &#8212; with Video">
								<img width="75" height="75" src="http://www.modelairplanenews.com/wp-content/uploads/2015/01/cut11-150x150.jpg" class="attachment-134x75 size-134x75 wp-post-image" alt="cut1" srcset="http://www.modelairplanenews.com/wp-content/uploads/2015/01/cut11-150x150.jpg 150w, http://www.modelairplanenews.com/wp-content/uploads/2015/01/cut11-60x60.jpg 60w, http://www.modelairplanenews.com/wp-content/uploads/2015/01/cut11-180x180.jpg 180w" sizes="(max-width: 75px) 100vw, 75px" />							</a> -->
							<a href="http://www.modelairplanenews.com/home-photo-shoot-full-spectrum-laser-cutter-review/" title="Desktop Laser Cutter &#8212; 40Watt hobby grade laser review &#8212; with Video"><img src="http://www.modelairplanenews.com/wp-content/uploads/2015/01/cut11.jpg" alt="Desktop Laser Cutter &#8212; 40Watt hobby grade laser review &#8212; with Video" class="Thumbnail thumbnail loop-main " width="310" height="190" /></a>										
					
					<a class="post-title  cat-post-title" 
						href="http://www.modelairplanenews.com/home-photo-shoot-full-spectrum-laser-cutter-review/" rel="bookmark">Desktop Laser Cutter &#8212; 40Watt hobby grade laser review &#8212; with Video					</a>

									</li>
				</ul>
</div><div id="text-111" class="widget-9 widget-odd widget-sidebar frontier-widget widget_text"><h4 class="widget-title">Subscribe Now Electric Flight</h4>			<div class="textwidget"><img id="EFmap" src="//www.modelairplanenews.com/wp-content/uploads/2017/02/SubscribeSidebarEF.jpg" border="0" width="275" height="200" orgWidth="275" orgHeight="200" usemap="#EFmap" alt="" />
<map name="EFmap" id="EFmap">
<area alt="Electric Flight" title="" href="https://www.circsource.com/store/Subscribe.html?magazineId=356&sourceCode=I1BBNR" shape="rect" coords="61,38,269,123" style="outline:none;" target="_blank"     />
<area alt="Electric Fight" title="" href="http://www.airagestore.com/magazines/digital/electric-flight-digital.html" shape="rect" coords="64,128,271,197" style="outline:none;" target="_blank"     />
<area shape="rect" coords="273,198,275,200" alt="Image Map" style="outline:none;" title="Image Map" href="http://www.image-maps.com/index.php?aff=mapped_users_0" />
</map></div>
		</div><div id="text-110" class="widget-10 widget-even widget-sidebar frontier-widget widget_text"><h4 class="widget-title">Newsletter Sign up</h4>			<div class="textwidget"><a href="#contact_form_pop" onclick="__gaTracker('send', 'event', 'download', '#contact_form_pop');" data-fancybox  class="newsletter-popup fancybox"><img SRC="  //www.modelairplanenews.com/members/files/2016/08/NEWSLETTERMAN.png" WIDTH="275" HEIGHT="218" BORDER="0"/></a>
<div style="display:none" class="fancybox-hidden">
<div id="contact_form_pop">
<iframe id="newsletteriframe" src="/newsletter.php" name="newsletteriframe" width="100%" height="310" frameborder="0" scrolling="no"></iframe></div>
</div></div>
		</div><div id="text-109" class="widget-11 widget-last widget-odd widget-sidebar frontier-widget widget_text"><h4 class="widget-title">Posts by brand</h4>			<div class="textwidget"><center><a HREF="http://www.modelairplanenews.com/manufacturers/" target="_blank"><strong>Posts by Brand</strong></a></center></div>
		</div>		
	</div>
	</div></div>

	<div id="footer" class="cf">
		<div id="widgets-wrap-footer" class="widget-column-4 cf">
			<div id="text-105" class="widget-1 widget-first widget-odd widget-footer frontier-widget widget_text">			<div class="textwidget"><a href="https://www.circsource.com/store/Subscribe.html?magazineId=354&sourceCode=I1BBNR"><img src="//www.modelairplanenews.com/wp-content/uploads/2017/03/BottomCovers-1.png"/></a></div>
		</div><div id="nav_menu-3" class="widget-2 widget-even widget-footer frontier-widget widget_nav_menu"><h4 class="widget-title">Model Airplane News</h4><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-245385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245385"><a href="https://www.circsource.com/store/Subscribe.html?magazineId=354&#038;sourceCode=I1BBNR">Print + Digital Edition</a></li>
<li id="menu-item-245386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245386"><a href="http://www.airagestore.com/magazines/digital/model-airplane-news-digital-edition-one-full-year-12-issues.html">Digital Edition</a></li>
<li id="menu-item-245387" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245387"><a href="https://www.circsource.com/store/Subscribe.html?magazineId=354&#038;type=gift&#038;sourceCode=I8AGNR">Gift Subscription</a></li>
<li id="menu-item-245388" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245388"><a href="https://www.circsource.com/store/renewalLogin.html?MagId=354">Renew</a></li>
<li id="menu-item-245389" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245389"><a href="https://secure.palmcoastd.com/pcd/eServ?iServ=MDY3QUw0MjA0Nw==">Subsciber Service</a></li>
</ul></div></div><div id="nav_menu-4" class="widget-3 widget-odd widget-footer frontier-widget widget_nav_menu"><h4 class="widget-title">Electric Flight</h4><div class="menu-ef-footer-menu-container"><ul id="menu-ef-footer-menu" class="menu"><li id="menu-item-245399" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245399"><a href="https://www.circsource.com/store/Subscribe.html?magazineId=356&#038;sourceCode=I1BBNR">Print + Digital Edition</a></li>
<li id="menu-item-245400" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245400"><a href="http://www.airagestore.com/magazines/digital/electric-flight-digital.html">Digital Edition</a></li>
<li id="menu-item-245401" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245401"><a href="https://www.circsource.com/store/Subscribe.html?magazineId=356&#038;type=gift&#038;sourceCode=I8AGNR">Gift Subscription</a></li>
<li id="menu-item-245402" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245402"><a href="https://www.circsource.com/store/renewalLogin.html?MagId=356">Renew</a></li>
<li id="menu-item-245403" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245403"><a href="https://secure.palmcoastd.com/pcd/eServ?iServ=MDY3QU00MTk4Mg==">Subscriber Service</a></li>
</ul></div></div><div id="nav_menu-2" class="widget-4 widget-last widget-even widget-footer frontier-widget widget_nav_menu"><h4 class="widget-title">Follow Us</h4><div class="menu-follow-us-container"><ul id="menu-follow-us" class="menu"><li id="menu-item-245367" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245367"><a href="http://www.facebook.com/ModelAirplaneNews"><i class="fa fa-facebook"></i></a></li>
<li id="menu-item-245368" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245368"><a href="https://twitter.com/modelairplane"><i class="fa fa-twitter"></i></a></li>
<li id="menu-item-245369" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245369"><a href="https://plus.google.com/b/112975876425768404660/112975876425768404660/posts"><i class="fa fa-google-plus"></i></a></li>
<li id="menu-item-245370" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245370"><a href="http://instagram.com/modelairplanenews"><i class="fa fa-instagram"></i></a></li>
<li id="menu-item-245371" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245371"><a href="http://pinterest.com/airplanenews/"><i class="fa fa-pinterest"></i></a></li>
<li id="menu-item-245372" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245372"><a href="https://www.youtube.com/user/AirAgeMedia1"><i class="fa fa-youtube"></i></a></li>
<li id="menu-item-245373" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245373"><a href="/?feed=rss"><i class="fa fa-feed"></i></a></li>
<li id="menu-item-245374" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245374"><a href="mailto:rccaraction@airage.com"><i class="fa fa-envelope"></i></a></li>
</ul></div></div>		</div>
	</div>

<div id="bottom-bar" class="cf">
		<nav id="nav-copyright">
		<ul id="menu-copyright-footer-menu" class="nav-copyright-footer"><li id="menu-item-245376" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-245376"><a href="http://www.modelairplanenews.com/about/">About</a></li>
<li id="menu-item-245377" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-245377"><a href="http://www.modelairplanenews.com/help-contact-us-electric-flight/">Help – Contact Us – Electric Flight</a></li>
<li id="menu-item-245379" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245379"><a href="/model-airplane-news-e-newsletter-sign/">Newsletter Sign Up</a></li>
</ul>	</nav>

			<span id="bottom-bar-text"><strong>Airage Media &copy; 2017</strong>  <div><span style="font-size: 9pt;line-height: 11pt">For all Licensing, Permissions, Awards and Reprint requests please contact our official partner Wright's Media for more information. Please note that Wright's Media is the only authorized company that we’ve partnered with for materials and assets. Wright's Media contact: <a>airage@wrightsmedia.com</a> or (877) 652-5295.</span> </span>
	
	
	</div>

</div>

<!-- Go to www.addthis.com/dashboard to customize your tools -->
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-57171b3ad2919f92"></script>

<!-- ngg_resource_manager_marker --><script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/uploads/shadowbox-js/2d1142f813908ef6cc5fefd5570340ef.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"http:\/\/www.modelairplanenews.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/plugins/wp-polls/polls-js.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/plugins/ultimate-responsive-image-slider/js/jquery.sliderPro.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-includes/js/comment-reply.min.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/plugins/page-links-to/js/new-tab.min.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/plugins/popover/inc/external/wpmu-lib/js/wpmu-ui.3.min.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/plugins/popover/js/public.min.js?aaver=e5ddfddaf4'></script>
<script type='text/javascript' src='http://www.modelairplanenews.com/wp-includes/js/wp-embed.min.js?aaver=e5ddfddaf4'></script>
<div id="wonderpluginlightbox_options" data-skinsfoldername="skins/default/"  data-jsfolder="http://www.modelairplanenews.com/wp-content/plugins/wonderplugin-lightbox/engine/" data-autoslide="false" data-slideinterval="5000" data-showtimer="true" data-timerposition="bottom" data-timerheight="2" data-timercolor="#dc572e" data-timeropacity="1" data-showplaybutton="true" data-alwaysshownavarrows="false" data-bordersize="8" data-showtitleprefix="true" data-responsive="true" data-fullscreenmode="false" data-closeonoverlay="true" data-videohidecontrols="false" data-titlestyle="bottom" data-imagepercentage="75" data-enabletouchswipe="true" data-autoplay="true" data-html5player="true" data-overlaybgcolor="#000" data-overlayopacity="0.8" data-defaultvideovolume="1" data-bgcolor="#FFF" data-borderradius="0" data-thumbwidth="96" data-thumbheight="72" data-thumbtopmargin="12" data-thumbbottommargin="12" data-barheight="64" data-showtitle="true" data-titleprefix="%NUM / %TOTAL" data-titlebottomcss="color:#333; font-size:14px; font-family:Armata,sans-serif,Arial; overflow:hidden; text-align:left;" data-showdescription="true" data-descriptionbottomcss="color:#333; font-size:12px; font-family:Arial,Helvetica,sans-serif; overflow:hidden; text-align:left; margin:4px 0px 0px; padding: 0px;" data-titleinsidecss="color:#fff; font-size:16px; font-family:Arial,Helvetica,sans-serif; overflow:hidden; text-align:left;" data-descriptioninsidecss="color:#fff; font-size:12px; font-family:Arial,Helvetica,sans-serif; overflow:hidden; text-align:left; margin:4px 0px 0px; padding: 0px;" data-videobgcolor="#000" data-html5videoposter="" data-responsivebarheight="false" data-smallscreenheight="415" data-barheightonsmallheight="64" data-notkeepratioonsmallheight="false" style="display:none;"></div><div class="wonderplugin-engine"><a href="http://www.wonderplugin.com/wordpress-lightbox/" title="WordPress Lightbox Plugin">WordPress Lightbox Plugin</a></div>
<!--Plugin WP Missed Schedule 2013.0130.2222 Active - 64Bit Security Tag Key: bkytCi8L522P8RbgYIlkQbL6Yz4JDvIWlTlXN5q776Yvq5t7gxkCvB643C7osdFV6-->
		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<script type='text/javascript'> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done"}};/* ]]> */ </script><script>window._popup_data = {"ajaxurl":"http:\/\/www.modelairplanenews.com\/wp-admin\/admin-ajax.php","do":"get_data","ajax_data":{"orig_request_uri":"\/jeti-transmitter-bracket-handle\/"}};</script><script type='text/javascript' src='http://www.modelairplanenews.com/wp-content/plugins/akismet/_inc/form.js?aaver=e5ddfddaf4'></script>
<script type="text/javascript">
jQuery(document).ready(function($) {
	$('#nav-main .drop-toggle').click(function(){
		$('#nav-main').toggleClass('dropped');
	});
});
</script>
<script type="text/css" id="tmpl-tribe_customizer_css">.tribe-events-list .tribe-events-loop .tribe-event-featured,
				.tribe-events-list #tribe-events-day.tribe-events-loop .tribe-event-featured,
				.type-tribe_events.tribe-events-photo-event.tribe-event-featured .tribe-events-photo-event-wrap,
				.type-tribe_events.tribe-events-photo-event.tribe-event-featured .tribe-events-photo-event-wrap:hover {
					background-color: #0ea0d7;
				}

				#tribe-events-content table.tribe-events-calendar .type-tribe_events.tribe-event-featured {
					background-color: #0ea0d7;
				}

				.tribe-events-list-widget .tribe-event-featured,
				.tribe-events-venue-widget .tribe-event-featured,
				.tribe-mini-calendar-list-wrapper .tribe-event-featured,
				.tribe-events-adv-list-widget .tribe-event-featured .tribe-mini-calendar-event {
					background-color: #0ea0d7;
				}

				.tribe-grid-body .tribe-event-featured.tribe-events-week-hourly-single {
					background-color: rgba(14,160,215, .7 );
					border-color: #0ea0d7;
				}

				.tribe-grid-body .tribe-event-featured.tribe-events-week-hourly-single:hover {
					background-color: #0ea0d7;
				}</script><style type="text/css" id="tribe_customizer_css">.tribe-events-list .tribe-events-loop .tribe-event-featured,
				.tribe-events-list #tribe-events-day.tribe-events-loop .tribe-event-featured,
				.type-tribe_events.tribe-events-photo-event.tribe-event-featured .tribe-events-photo-event-wrap,
				.type-tribe_events.tribe-events-photo-event.tribe-event-featured .tribe-events-photo-event-wrap:hover {
					background-color: #0ea0d7;
				}

				#tribe-events-content table.tribe-events-calendar .type-tribe_events.tribe-event-featured {
					background-color: #0ea0d7;
				}

				.tribe-events-list-widget .tribe-event-featured,
				.tribe-events-venue-widget .tribe-event-featured,
				.tribe-mini-calendar-list-wrapper .tribe-event-featured,
				.tribe-events-adv-list-widget .tribe-event-featured .tribe-mini-calendar-event {
					background-color: #0ea0d7;
				}

				.tribe-grid-body .tribe-event-featured.tribe-events-week-hourly-single {
					background-color: rgba(14,160,215, .7 );
					border-color: #0ea0d7;
				}

				.tribe-grid-body .tribe-event-featured.tribe-events-week-hourly-single:hover {
					background-color: #0ea0d7;
				}</style>
<!-- Begin Shadowbox JS v3.0.3.10 -->
<!-- Selected Players: html, iframe, img, qt, swf, wmp -->
<script type="text/javascript">
/* <![CDATA[ */
	var shadowbox_conf = {
		animate: true,
		animateFade: true,
		animSequence: "sync",
		modal: false,
		showOverlay: true,
		overlayColor: "#000",
		overlayOpacity: "0.8",
		flashBgColor: "#000000",
		autoplayMovies: true,
		showMovieControls: true,
		slideshowDelay: "3",
		resizeDuration: "0.35",
		fadeDuration: "0.35",
		displayNav: true,
		continuous: false,
		displayCounter: true,
		counterType: "default",
		counterLimit: "10",
		viewportPadding: "20",
		handleOversize: "resize",
		handleUnsupported: "link",
		autoDimensions: false,
		initialHeight: "160",
		initialWidth: "320",
		enableKeys: true,
		skipSetup: false,
		useSizzle: false,
		flashParams: {bgcolor:"#000000", allowFullScreen:true},
		flashVars: {},
		flashVersion: "9.0.0"
	};
	Shadowbox.init(shadowbox_conf);
/* ]]> */
</script>
<!-- End Shadowbox JS -->


<!-- <noscript><img src="https://airage-validate.onecount.net/onecount/oc_track/tracker_nojs.php?_ca=OC-AIRAGE-01152016" style="border:0" alt="" /></noscript>
<div style="display:none"><a href="https://airage-validate.onecount.net/onecount/oc_track/creditcardlist.php?_ca=OC-AIRAGE-01152016" style="border:0" alt="">click me</a></div> -->
</body>
</html>